Category Archives: IT Stuff

Exclude filetypes with rclone

If you want tofilter filetypes synced by rclone, the following is what you need:

--exclude=*.jpg --exclude=*.txt

and test it using rclone ls remote: -vv

and you can combine them like so
--exclude=*.{jpg,txt}

Plex Database Cache Setting

The comands below are for Plex in Docker, however you can change the paths relevant to any Plex install.

To get current cache size…

sqlite3 "/opt/appdata/plex/database/Library/Application Support/Plex Media Server/Plug-in Support/Databases/com.plexapp.plugins.library.db" "PRAGMA default_cache_size;"

Change cache size (and confirm value)

sqlite3 "/opt/appdata/plex/database/Library/Application Support/Plex Media Server/Plug-in Support/Databases/com.plexapp.plugins.library.db" "PRAGMA default_cache_size = 6000000;" "PRAGMA default_cache_size;"

The default cache size is 20000, if you have thousands of movies and tv shows set it to a larger value (I changed it to 6000000, but any number will work for you)

Before making changes to the sqllite database stop the plex server and service then edit and restart.

also change the paths to your plex installation paths as mine are custom.
ALWAYS MAKE A BACKUP FIRST OF YOUR ENTIRE INSTALLATION FOLDER AND DATABASE STUFF!!!

Windows Server 2019/2022 Unknown Device BTH\MS_BTHPAN

Summary

Instructions to resolve unknown device appearing labeled Hardware ID BTH\MS_BTHPAN after installing Windows Server 2019 or 2022 and all drivers for Intel® NUC8i3/v5/v7PN products.

Description

After installing Windows Server 2019 and all available drivers, an Unknown Device appears in Device Manager.

Resolution

Perform the following steps to install drivers for the unknown device:

  1. Open Device Manager and double click the unknown device 
  2. Click the Details tab
  3. Click the dropdown and select Hardware Ids
  4. Confirm that the Hardware ID is BTH\MS_BTHPAN
  5. Click the Driver tab
  6. Click Update Driver > Let me pick from a list of available drivers on my computer > Bluetooth, then click next
  7. Select Microsoft from the Manufacturers list on the left, select Personal Area Network Service from the list on the right
  8. Click Yes on the “Update Driver Warning” dialog that appears

Official Windows 7 SP1 ISO Image Downloads

These are now available for those who currently have Microsoft Windows 7 with Genuine Activation Keys. These are the legitimate downloads, full ISO image to burn to a good quality blank DVD using any good image burning program such as ImgBurn or the like.

These ISO image download have Service Pack 1 integrated into the installation setup, so therefore there is no need to separately install SP1 after the initial install of Windows 7.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Windows 7 SP1 ISO Download Links Including English and Foreign Language Versions:

 

These are very high speed downloads which should take anywhere from 30 minutes to about 50 minutes, if you have a high-speed broadband connection.

My download took approximately 18 minutes from start to finish. Both IE9 and Firefox have their own download managers you may use to accomplish the download.

Thеѕе аrе NOT illegal – Thеѕе аrе јυѕt thе download links fοr Windows 7 SP1 ISO whісh іѕ a retail wrap thаt offers a 30-day trial period. Yου need tο activate уουr Windows afterwards wіth a genuine license activation key tο continue using іt. Downloading thеѕе files frοm Digital River іѕ absolutely legal аnԁ completely free οf charge.

Link Aggregation on Cisco Switch

First, you need to access the console of your Cisco Switch.

In our example, we are going to use an Opensource software named Putty and a computer running Windows.

The Putty software is available on the putty.org website.

After finishing the download, run the software and wait for the following screen.

To access the console of a Cisco Switch model 2960 or 3750, you will need to select the Serial Connection category and use the following options:

• Connection type: Serial
• Serial line: COM1
• Speed: 9600

If COM1 does not work you will need to try to use COM2, COM3, COM4 or the next.

Using either the console, telnet or ssh, connect to the command-line of your switch and log in with a user who has administrative privileges.

On the prompt screen, enter the administrative login information.

After a successful login, the console command-line will be displayed.

Switch>

Use the enable command to enter the privilege mode.

Switch> enable

Use the configure terminal command to enter the configuration mode.

Switch# configure terminal

Create a new vlan, select an identification number and add a brief description.

Switch(config)# vlan 100
Switch(config-vlan)# name Voip Network
Switch(config)# vlan 200
Switch(config-vlan)# name Data Network
Switch(config-vlan)# exit

On the configuration mode, you need to clear all the configuration from the switch port.

Switch(config)# default interface gigabitEthernet 0/21
Switch(config-if)# default interface gigabitEthernet 0/22

On the configuration mode, add the switch ports to a link aggregation group.

Switch(config)# interface gigabitethernet0/21
Switch(config-if)# channel-group 1 mode active
Switch(config)# interface gigabitethernet0/22
Switch(config-if)# channel-group 1 mode active
Switch(config-if)# exit

In our example, the switch ports 21 and 22 were configured as members of the link aggregation group 1.

To configure the link aggregation ports as a Vlan member, you need to use the following commands.

Switch(config)# interface Port-channel 1
Switch(config)# switchport mode access
Switch(config-if)# switchport access vlan 200
Switch(config-if)# exit
Switch(config)# exit

In our example, the Switch port group 1 was configured as a member of VLAN 200.

To configure the link aggregation ports as a Trunk, you need to use the following commands.

Switch(config)# interface Port-channel 1
Switch(config)# switchport mode trunk
Switch(config-if)# switchport trunk native vlan 1
Switch(config-if)# switchport trunk allowed vlan add 1,100,200
Switch(config-if)# exit

In our example, the Switch port group 1 was configured as a trunk.

The trunk configuration allows the communications of Vlans 1, 100 and 200.

Don’t forget to save your switch configuration.

Switch# copy running-config startup-config

You have successfully configured a link aggregation on a Cisco switch 🙂

WinSCP as Sudo Root

To allow for a WinSCP session to operate as sudo the following string can be added.  Thai ia most useful when attempting to change the content of config files that are owned by the root account.

sudo su -c /usr/lib/sftp-server

Found on the advanced settings page for your site:

 

 

Restart Veeam Services

If the occasion arises that requires a restart of your Veeam backup server, you can try restarting the Veeam services to avoid restarting the host server.

Open Powershell as Admin and use the following commands:

Get-process | where {($_.Name -like “Veeam*”)} | stop-process -Force
Get-Service | where {($_.Name -like “Veeam*”)-and ($_.Status -eq “Running”)} | Stop-service -Force
Get-Service | where {($_.Name -like “Veeam*”)-and ($_.Status -eq “Stopped”)} | Start-service

 

 

 

 

 

Veeam Rename HyperVisor host

If you have renamed HyperV Hostname and Veeam cannot connect to enumerate the VMs running, use this script to change the hostname of the HyperVisor:

Asnp VeeamPSSnapin
$server = Get-VBRServer | ?{$_.name -eq "IpOfVC"}
$server.SetName("NewIP")

This will rename the host from the existing in Veeam to the new one you have set.  No reboot required.